Child pages
  • Glide Docking Tutorial: Docking on an RNA receptor

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 5.3

...

USECOMPMAE YES

INNERBOX 10, 10, 10

ACTXRANGE 30.000000

ACTYRANGE 30.000000

ACTZRANGE 30.000000

GRID_CENTER 9.940000, -8.310000, -11.660000

OUTERBOX 30.000000, 30.000000, 30.000000

ENTRYTITLE 3TZR

GRIDFILE .// grid.zip

RECEP_FILE 3TZR_prepared.mae

where the 3TZR_prepared.mae is a presaved version of the prepared receptor file. Then, you can run glide from the command line to generate the grid file:

...

If you do not fix this, you will end up with a lot of unexpected ring conformations and some extra protons in the prepared ligands. So choose “2D Sketcher” with a hammer sign from the “Edit” menu or from the tool bar:

...

It is possible to change between ligands when this window is open. 

Managing charges before docking

Normally, Schrodinger programs use OPLS charges to prepare the receptor and ligand. However, there are cases down the road in which you may need to use other types of charges in the docking procedure. On the other hand, you may want to prepare your ligand conformations in other programs, but assign them the OPLS charges for docking. Anyway, it is a good idea always to use the same type of charges and van der waals (vdw) parameters for both the ligand and receptor in every single docking experiment.

Let us begin with generating OPLS charges for a set of pre-generated conformations of a ligand. This is useful when you want to keep certain protonation state, ring conformation, aromaticity, etc. for the ligand from previous experimental or MD structures, but still want to use the OPLS charges. So you can import the file containing one or a set of ligands into the maestro and use the Project Table to select all of the ligands. Then you need to click on "Assign Partial Charges" in the "Tools" menu and export the ligands as to a new mae file:

Image Added

It is always useful to take a look at the original file and the recently-exported mae file to check if "only" the charges are changed and not other properties of atoms. Fortunately, maestro comes with a nice labeling tool by which you can check several properties of each atom, including its partial charge. To use it, you need to click the "Atom Labels..." in the "Workspace" menu which opens a side window named "Atom Labels": 

Image Added

You can click on "Add..." in this window to add the specific properties that you want to label your atoms with: 

Image Added

After choosing the properties, you can pick any atom in the work space and it will be labeled with the properties you had chosen. 

Now, imagine that you want to use amber charges for the receptor and RESP or AM1-BCC charges for the ligand, but still want to use glide docking algorithm and score function. To do this, first you need to have the receptor and ligand files with desired charges in mol2 format. Then you should import the mol2 files into maestro and export them with mae format. For grid generation step, follow the same steps as mentioned before, but check the "Use input partial charges" in the Receptor Grid Generation window:

Image Added

Glide generates the OPLS partial charges for the ligands in docking procedure and does not respect the charges already present in the ligand mae file. However, if you want glide to respect the pre-generated partial charges in the mae file, you need to check "Use input partial charges" in the "Ligands" menu of the "Ligand Docking" window as you are setting up the glide input file: 

Image Added

This will add a line to the glide input file as:

LIG_MAECHARGES YES

Finally, if you are using charge types other than OPLS, it is important to use the compatible vdw parameters as well. For example, if you use the AMBER/RESP charges, you need to use the AMBER vdw parameters instead of OPLS_2005 which SCHRODINGER programs normally use. OPLS_2005 vdw parameters are accessible in the following file:

$SHRODIINGER/mmshare-v<version>/data/f14/f14_oplsaa.vdw

in which <version> indicates the version of the SCHRODINGER you are using. If you want to use a modified set of vdw parameters, you need to copy this file to the following path:

$HOME/.schrodinger/mmshare/

Then you need to modify it according to the desired force fields that are compatible with the charges you are using. This file will be used in preference to its installation version. Just make sure to remove it after you finished the docking experiment with non-OPLS charges. 

To change the vdw parameters, you need to know the vdw types of the atoms, which are defined in the following file:

$SHRODIINGER/mmshare-v<version>/data/f14/f14_oplsaa.type

in which the second column is the vdw type. Each vdw type can match several different atom types. For details about how to change any OPLS force fields, check the following link:

ftp://ftp.schrodinger.com/support/hidden/TS/modifying_opls.txt